Bugs

Post Reply
Grégory
Posts: 11
Joined: Thu Oct 06, 2011 10:10 am

Bugs

Post by Grégory » Thu Oct 06, 2011 12:53 pm

Bug lors de l'installation de "Aspi-Tirésias" (renommé comme ça pour éviter confusion avec Tirésias-I) sur Windows 7 (édition familiale Premium), service pack 1, 32 bits.
Les applications sont dans C: (donc C:\Program Files\Aspi-Tiresias), les documents dans D: (D:\gregory\Mes Documents).
Un dossier Prospéro-II a été automatiquement placé dans D: (D:\gregory\Mes Documents\Prospero-II), mais ça n'a pas été le cas pour Tirésias.
Pas de problème avec Tirésias-I (chemin = C:\Program Files\Doxa\Tiresias).

Lors de l'ouverture du fichier .exe, affichage du message d'erreur suivant (capture d'écran en PJ) :

The logfile 'C:\Program Files\Aspi-Tiresias\app_tiresias.exe.log'
[Errno 13] Permission denied: 'C:\\Program Files\\Aspi-Tiresias\\app_tiresias.exe.log'


Test fait avec Jean-Pierre : mettre le fichier 'exe.log' à la poubelle. Mais pas de changement.

Pour info, il y avait déjà eu des phénomènes curieux avec le même ordinateur (notamment, Prospéro I retrouvait des fichiers de concepts qui n'apparaissaient pas dans le visualiseur Windows, et même en passant par le DOS).
Attachments
Bug-AspiT-1.PNG
Bug-AspiT-1.PNG (20.01 KiB) Viewed 12333 times

jean-pierre charriau
Posts: 72
Joined: Sun Oct 09, 2011 12:11 pm

Re: Bugs

Post by jean-pierre charriau » Tue Oct 11, 2011 3:49 pm

est-ce que le les dossiers :
Tiresias
Tiresias\scripts
Tiresias\data
ont bien été créés sous c:\gregory\Mes Documents ?

JP

Grégory
Posts: 11
Joined: Thu Oct 06, 2011 10:10 am

Re: Bugs

Post by Grégory » Wed Oct 12, 2011 3:49 pm

jean-pierre charriau wrote:est-ce que le les dossiers :
Tiresias
Tiresias\scripts
Tiresias\data
ont bien été créés sous c:\gregory\Mes Documents ?
JP
Dans d:\gregory\Mes Documents tu veux dire?
Non, ils n'ont pas été créés (ni dans d: ni dans c:).
Je dois les créer moi-même ou pas ?

Par ailleurs j'ai essayé d'ouvrir l'actualisation (même chemin qu'avant : C:\Program Files\Aspi-Tiresias) et cette fois je n'ai plus le message d'erreur, mais à la place une fenêtre qui s'affiche 1 sec et disparaît aussitôt.

Il y a un fichier log de 800 ko qui va avec, je l'envoie ou le mets en PJ si besoin.

jean-pierre charriau
Posts: 72
Joined: Sun Oct 09, 2011 12:11 pm

Re: Bugs

Post by jean-pierre charriau » Wed Oct 12, 2011 4:36 pm

le programme d'installation installe correctement l'application, mais il doit aussi installer sous user\Document , un dossier Tirésias contenant un sous-dossier script qui contient les scripts python.
Dans inno setup ça se traduit par ... DestDir: "{userdocs}\Tiresias\scripts" où userDocs doit être remplacé à l'exécution du prog d 'installation par le dossier Document de l'utilisateur. il semble que ce soit là que ça coince !
as-tu trouvé quelque part, égarés sur ton disque dur, les scripts en question ?
sinon je te les envois et il faudra créer le dossier Document\Tiresias\scripts (sous c: puis tenter D: , le prog aspi-tireseias utilise aussi une variable user qui peut ne pas pointer au bon endroit ...)
et y copier les scripts.

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests